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1 Introduction 

What is CheckCon 

CheckCon is a software package for the automated testing of current and voltage 
transformers. CheckCon has been designed for use with the test systems and 
equipment of ZERA GmbH, Königswinter. 

The CheckCon programs support all individual tasks during the test. This includes 
the generation of test sequences and error classes, running manual and fully auto-
mated tests as well as generating reports and performing an evaluation. 

About this Guide 

Style and Markup 

The User Guide at hand addresses all users that are to work with CheckCon. It de-
scribes the layout and operation of the program and all its elements. 

This documentation uses a number of different styles and markups to highlight or 
identify specific control elements, identifiers, text entries or key combinations. On 
the one hand, this indicates the links of the read material to the software programs, 
and on the other hand it creates an opportunity for quickly identifying a particular 
option in the text. For that particular reason, elements which a user is most likely 
to look for by scanning the text are printed in bold face font. 

The styles and markups are consistently used in following manner: 

Mouse 

This documentation refers to the mouse by the expressions ‘mouse button’ and 
‘mouse wheel’ in order to avoid confusion with other input devices or interactive 
elements. The mouse functions in the manner common for Microsoft Windows: 

� ‘Click’ or 'left click’ on a particular object generally refers to one short click on 
the left mouse button while the mouse pointer is positioned on top of the respec-
tive object on the screen. The different designations ‘clicking on an item,’ 'click-
ing in an item' or ‘clicking an item' merely arise from the visual context and 
function in an identical manner.  

� A ‘right click,’ while it functions in a manner similar to a left click, is performed 
with the right mouse button. A ‘middle click’ is still rather uncommon for PCs. If 
the mouse exhibits a middle button, a ‘middle click’ is performed by means of 
the middle button in a manner similar to the one described above. Depending on 
the operating system and the model of the mouse, the mouse driver might simu-
late a non-existent middle button. 

� ‘Double-click’ refers to a fast sequence of two short left clicks on the same object 
while the mouse remains mostly stationary. The sensitivity with regard to the 
clicking sequence and the shifting tolerance can generally be adjusted by means 
of the mouse driver. 
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Keyboard 

While working with the present software program, you will perform entries via the 
keyboard at different occasions. Throughout this documentation, the term ‘key’ in 
the context of data input always refers to a key of your keyboard. 

The following differentiations indicate the various types:  

� Pressing a key is indicated by means of angle brackets. Example: <a> or <A> 
refer to the key ‘A’. If capitalization is important, it will be explicitly stated in the 
text. 

� Whenever possible, identifiers for individual keys are indicated in the manner 
they can be found on a standard English keyboard:   
<F1>, <F2>, ..., <F12>,  
<Alt>, <AltGr>, <Ctrl>,  
<Ins>, <Del>, <Home>, <End>. 

� The following identifiers are used for keys that do not exhibit a label:  
<Enter> refers to the return/enter key,   
<Backspace> refers to the backspace key,   
<Space> refers to the space bar,   
<Shift> refers to the shift key,   
<Caps Lock> refers to the caps lock key and  
<Tab> refers to the tab key. In addition, the cursor keys are indicated by  
<Left>, <Right>, <Up>, <Down>, <Pg-up> and <Pg-dn>.    

� Keys on the separate keypad are identified by the prefix Num:  
<Num1>, <Num,>, <Num/>, etc. 

� Key combinations, i.e. keys which need to be pressed at the same time, are indi-
cated by means of the sum of the respective keys. Example: ‘Press <Alt+X>.’ - In 
order to enter such a combination, press and hold down the first key (in this 
case <Alt>). While you hold down the first key, press and release the second key 
(in this example <X>). If the text contains no other instructions, press and 
quickly release the second key. Subsequently release the first key. Generally 
such combinations include the keys <Shift>, <Alt> and <Ctrl> as the first key 
and an additional second key. 

� Key combinations with more than two keys are only used in combinations with 
<Shift>, <Alt> and <Ctrl> as the first key, e.g. <Shift-Ctrl+F2>. The sequence for 
pressing the first keys is of no importance in that context. Please make sure that 
all keys are pressed when you press the last key (in this example <F2>). <Ctrl-
Shift+F2> is identical to the above example. For that reason, the combination of 
these keys is indicated by means of a hyphen. 

� There are occasions when you need to enter text in the manner indicated in this 
documentation, e.g. particular names or commands. Such text is indicated in a 
non-proportional font. 

� A non-proportional font is also used for file, directory and path names. 

Controls 

Typical controls of the display contents are particularly highlighted: 

� The names of menus and commands, options, tabs, input boxes, table headers 
and window ranges are printed in italics. Example: ‘For detailed settings, click 
on the tab Extras' or ‘Select the desired documents in the panel Contents.’  

� A special notation is used for menus. Accessing a desired command generally 
involves clicking on a menu name and a submenu. This is represented by the 
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common abbreviated form ‘Menu name > Submenu > Submenu > ... > Com-
mand.‘ Example: ‘Click on Extras > Databases > Program Databases’ stands for 
‘From the main menu of the program, click the menu title Extras and choose the 
submenu Databases. There, select the command Program Databases.’  
Unless otherwise indicated, such a menu path always originates from the main 
menu of the main window. The Windows start menu forms an exception and is 
represented by ‘[Start] > Programs > ….’ This naturally refers to the button 
[Start] on the Windows taskbar. 

� The names of windows and dialogues, buttons, option buttons and check boxes 
are indicated in bold or italics. The names are always printed in bold if they ap-
pear in a functional context and require particular highlighting. If the names are 
only mentioned, they are printed in italics. Example: ‘This opens the dialogue 
Advanced Settings.’ but ‘The control elements function similar to the dialogue 
Advanced Settings (see above).’ 

� In addition, buttons are indicated by square [brackets]. ‘Button’ generally refers 
to a control on the screen. If a button is explicitly mentioned in the text, this al-
ways implies a left click on that button. Example: ‘Confirm your changes with 
[OK].’ This indicates the presence of a button named ‘OK’ in the respective dia-
logue. If you click on the button, any changes you might have performed with 
regard to the settings are accepted and saved.  
Button names printed in bold face indicate, that the control is labeled with the 
name, button names in italics refer to buttons that are only named as stated in 
the text. For instance [Print] refers to a button that reads ‘Print’ in letters, [Print] 
instead refers to a button that is named ‘Print’ and introduced earlier in the text, 
and does not show its name but most likely a symbol or picture instead. 

Links 

� References to text passages within this documentation are printed in italics. 
Chapters and sections are divided by means of a hyphen. Example: ‘For details 
about the command Print Preview, please refer to section Common Functions – 
Print Preview.’ 
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2 Installation 

CheckCon is installed using the standard software InstallShield. The installation 
must be performed with administrative privileges. 

System Requirements 

Operating System 

CheckCon runs on the Microsoft operating systems Windows 2000 und Windows 
XP. Up to the current version, CheckCon does not require any service packs or 
patches. No known conflicts exist with any Windows service pack released prior to 
this CheckCon version, which are all up to service pack 4 for Windows 2000 and 
service pack 1 for Windows XP. 

Hardware 

CheckCon communicates with the devices of the test equipment via serial interfaces 
of the common type RS232. CheckCon supports up to 8 different devices, each con-
nected to a separate interface (see section 6 settings for details).  

As a result, the PC must be equipped with a number of RS232 interfaces equal to 
the maximum number of devices you want to connect. 

System Performance 

CheckCon does not impose any considerable strain to system resources. Any PC 
capable of running the installed operating system smoothly, will be sufficiently pow-
erful for CheckCon. 

First Installation 

You can simply insert the CheckCon CD and run Setup.exe from its root directory. 
However, it is recommended to first copy the content of the CD to your hard disk 
into a directory of your choice and run Setup.exe from there. This will leave you 
independent from the setup CD from there on. 

If, in order to perform the setup, system files must be installed or updated, you 
might get asked to reboot the machine. Please do so (by confirming the correspond-
ing dialogue with [Yes]) before continuing with the setup. If the setup does not 
commence automatically after the reboot, please execute the Setup.exe again. 

When the setup is ready, you will first be asked to se-
lect the setup language. 

This selection not only influences the setup language 
but also determines the installed language version of 

CheckCon 2005. In the dialogue, just select your language of choice from the drop-
down menu, and click [OK]. 
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The installation is performed using the Win-
dows standard installer software InstallShield. 
The first screen just tells you about the up-
coming setup, please click [Next>]. 

 

 

 
 

 

 

Choose between a complete and a customized 
(user defined) installation and click [Next>]. A 
full setup automatically installs to the direc-
tory 

C:\Program Files\  
     Esoes\ 
    CheckCon 2005   

If you select the customized setup, the next 
step allows you to specify an alternative loca-
tion. 
 
 

The selected directory defaults to the standard 
program directory as stated above. You can 
[Change] this selection.  

You can not alter the component selection.  

After you specified the correct installation 
path, click [Next>].  

This step is skipped for a full installation. 

 
 

 

Click [Install] to proceed, [<Back] to change a 
setting or [Cancel] the setup. 
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The setup tells you, when CheckCon 2005 has 
been completely installed. Click [Finish] to 
close and leave the setup program.  

 

 

 

 

 

 

 

Modify, Repair, Uninstall 

In order to remove or repair an existing instal-
lation, simply rerun the setup. The following 
options will be available: 

Add or remove features leads to the dialog of 
the customized / user defined setup. Since 
CheckCon always installs completely without 
selectable features, this option is useless with 
CheckCon 2005. 

Reinstall or repair replaces all installed files 
with their originals from the setup medium. 
This is the thing to try if you suspect that one 

of the installed files has been damaged. 

Uninstall completely removes CheckCon from your system. Please always use this 
way to uninstall CheckCon. Do not manually delete files or folders from your disk, 
since proper deinstallation will most probably not be possible afterwards. 

Select the required option and click [Next>]. Proceed as described under First Instal-
lation above. 
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3 Common Features 

Login 

CheckCon includes an internal user base. When you start the application, you are 
asked to enter your login name and a password. 

Enter your CheckCon user name and the corre-
sponding password. 

If you don’t have a CheckCon user account at your 
disposal, please check with your CheckCon Ad-
ministrator. 

If you installed CheckCon for the first time, login 
as Administrator. The default password for this account is CheckCon. Please change 
this to something less obvious immediately after first login. 

Details about the user management, about linking CheckCon user accounts to 
Windows user accounts and about auto-login are described in section 4 (Connection 
to System Users). 

Commit your login with [OK]. If you [Cancel], the login dialog is completely ignored. 
If you cancel the login at program start, the program will be finished immediately. If 
you cancel a re-login (see next subsection), you do not switch to the new account 
but continue to work under the last valid login. 

In order to work with CheckCon 2005, there must always be a user logged on to the 
program. However, no explicit logoff is required, logoff is performed automatically 
on re-login or on program exit. 

The menu item Login 

Login is also a menu item in CheckCon, allowing fast re-login without the need to 
logoff or restart the program. This allows for instance to switch between accounts 
with different permission levels, or to easily share the client machine between sev-
eral users. 

The menu Login <Alt+L> has the following items: 

Login 
Opens the Login dialog as shown above. Allows fast re-login to the running pro-
gram. Implicitly logs off the previous account. 

Stop <Alt+F4> 
Exits the program. Implicitly logs off. 

Print and print preview 

CheckCon is capable of printing specific information in a processed form. The 
printer set to be the standard printer under Windows, here referred to as standard 
printer, is used for all paper printouts.. 

The quick printing functions of the program can be accessed via the 
several Print...-buttons on the toolbar, which print the selected re-
port immediately and without further dialogs. 
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As an alternative to quick printing, at least for protocols, you can a preview. 
This is a screen representation of the printout to be expected on the selected 
printer. The print preview is generated by means of the printer driver of the 

current standard printer. This ensures that the layout displayed on the screen cor-
responds to the layout of the paper printout.  

 

The print preview window features its own toolbar. It shows the current page num-
ber and the total page count. In case of multipage documents, you can switch be-
tween pages by means of the arrow icons. 

Zoom 

With the drop-down box on the left, you can select from several zoom lev-
els. 

Print 

The document shown on the preview screen will be sent to the device that is 
specified as default printer under Windows, to be printed with the current set-
tings. When you issue the print from the preview window, another dialog is shown, 
before actually printing the document. 

 

Here you can specify a page range, the number of copies and the sorting. 

Export to file 

Instead of printing the document on paper, you can export the document to a 
file. Click the Export-icon to open the export dialog, where you can choose from 
a wide range of different formats (pdf, csv, xls, several database types, etc.) and one 
of several export targets (file, email, application, etc.).   

Closing the print preview 

Simply close the print preview by means of the appropriate Windows control ele-
ment ( ) or press <Alt-F4>. 
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Working with tables 

CheckCon uses tables for the structured display of data. Some allow editing within 
the table view. Such a table is always connected to a database and usually one line 
in the table represents one set in the database. 

Tables for display purposes 

Tables that only serve display purposes work as you know it from Windows: Click-
ing into a cell marks the whole line. Adding <Ctrl> or <Shift> allows multiple selec-
tions. Clicking a column header sorts the table by the entries of that column, addi-
tional clicks reverse the sorting order, indicated by the sorting marker. 

If need be, the width of a column can be adjusted by dragging and dropping the 
width control, the separator between two adjacent columns. A double click auto-
sizes the column width. 

 

Tables that allow editing 

Tables that allow editing of their content are a bit more complex. 

In addition to the column headers these tables feature line headers. Like the width 
control, line header separators work as height control. 

Highlighting 

Clicking a column or line header highlights the whole column or line respectively. 
Clicking into a cell selects the data field for editing. Multiple selections with <Ctrl> 
and <Shift> is generally possible, but might be disabled in some dialogs partially or 
completely. 

sorting marker column header width control scroll bar 

line header 

active line 
active cell 

column header width control 

new line height control 
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A black arrow in a line header indicates the active line. This is useful for instance 
when several lines are highlighted but a command is issued that only affects the 
active line.  

Editing cells 

Editing of values happens immediately within the table cell. An active cell can be 
edited, which can happen in one of three different ways in CheckCon 2005: 

The simplest case is a checkbox. It works just like any checkbox and can be either 
checked or unchecked, which is empty. 

Where there is defined set of choices exceeding yes and no, the cell 
usually features a drop-down box to select the value from. The drop-
down control (the downward arrow button) will become visible whenever 
the cell becomes active. You can select an entry from the drop-down list 
with the mouse, scroll through the list with the cursor keys or simply 

start typing, which will select the first value alphabetically that matches your input. 
Available values in a drop-down list might depend on values specified in other cells. 
In this case, the list does not feature all possible values for the field, but only those 
that are valid in the given combination. 

The third possibility are cells with free text editing. Apart from possible probability 
checks, these fields accept any input you enter. A single click in such a cell high-
lights the whole entry. As known from Windows, the entry is replaced with your in-
put as soon as you start typing. If you want to retain the current value for editing 
instead of replacing it, click a second time into the cell, which will position the cur-
sor within the current entry. 

Adding lines 

To add a new line to the table, you can enter data into the bottommost line, the one 
marked with an * in the line header, at any time. As soon as you start entering data 
into this line, a new bottommost line appears, now bearing the * in its line header, 
while the incomplete line you just started is indicated by a pen in its line header. 

Clearing cells 

As a cell is part of a line, cells can only be deleted as a whole line. Individual cells 
can only be emptied, provided they do not contain mandatory fields. 

Deleting lines <Entf> 

After highlighting one or more lines, you van delete them by hitting <Del>. This 
empties all related cells and deletes them from the table. A confirmation request 
prohibits accidental deletion of data.  

Please be aware that the <Del> key always works on the currently selected ele-
ments, which in a bigger dialog may not necessarily be a table element. 
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4 User Manager 

CheckCon includes and facilitates a separate user management. You can access it 
via the menu Extras > User manager.  

The two main parts of the user management are displayed separately on the two 
registers Users, featuring the list of the CheckCon User accounts, and Connection to 
system users allowing Windows account integration. 

Users 

Account List 

This list contains all user accounts 
set up for CheckCon. The account 
Administrator is required and prede-
fined. Per default, this user is 
granted full access to CheckCon. 
The CheckCon administrator does 
not necessarily require administra-
tor privileges to the Windows sys-
tem. However, to avoid access limi-
tations by Windows, a user working 
as CheckCon administrator requires 
Windows change privileges to the 
CheckCon program directory, in-
cluding all subdirectories and files, 
as well as the CheckCon databases, 
should they be stored in a different 
location. 

The section Connection to System 
Users below describes a method for 
associating Windows and CheckCon 
user accounts and configuring an 
automatic login. 

Strategies for Setting up CheckCon Users 

We recommend determining a strategy prior to setting up users under CheckCon. 
Please also review Connection to System Users. 

There are generally two strategies for setting up users for programs which (similar 
to CheckCon) facilitate a user management separate from Windows: 

Personalized User Accounts 

One strategy consists of setting up a CheckCon user account for each Windows 
user that is authorized to use CheckCon, ideally under the same name. This pro-
vides a simple method for associating Windows and CheckCon users.  

As you need to set up an individual CheckCon account for each potential CheckCon 
user and manage the CheckCon permissions for each of these accounts individu-
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ally, this strategy, while being the simplest to the users, will require higher admin-
istrative action for a larger user base. 

Role-based User Accounts 

An other strategy involves initially determining the essential functions or roles of 
the users operating CheckCon. For the purpose of user management, each role can 
be expressed as a set of user permissions. 

If a number of individuals operating CheckCon hold the same role with regard to 
CheckCon permissions, then one shared CheckCon account will be sufficient for 
these individuals to log into CheckCon. 

The above picture shows a setup with role based users, setup, editor and tester.  

The rights for the roles can be assigned exclusively. For example, the editor is al-
lowed to edit all the databases but not authorized to test. The tester may only test 
and print results. The setup user may configure program options and access the 
user management but not the databases. As a result, the respective individual 
would need to log in as editor to configure the test data and as tester prior to test-
ing. While this method is more secure, it is also more cumbersome. 

To avoid this problem, the appropriate rights can be assigned inclusively. In the 
example, the tester remains restricted to testing and processing results, while the 
editor gets assigned the permissions of the tester additionally. The setup user can 
be ignored, as the combined permissions of the exclusive setup, editor and tester 
result into the role of the administrator. 

The disadvantage is that several users share the same account, which might com-
promise individual responsibilities. 

Combined strategy 

Windows user accounts are usually personalized. For programs like CheckCon, 
role-based accounts greatly minimize the administrative burden, just like user 
groups in the Windows user management. By means of the mechanism for connect-
ing CheckCon and Windows user accounts, CheckCon allows you to exploit the 
benefits of both strategies. For further details, please refer to the section Connection 
to System Users below. 

Edit the Account List 

In order to edit the account list you must logon with 
an account that has the manage user right. All other 
users can only change their own password here. 
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Add account 

In the account list, click [Add] to 
open the dialog New User. 

Assign a Login name, the name that 
needs to be entered as user name at 
logon. 

Name and Description serve a pro-
per description of user accounts. 
They are irrelevant to the system. 

Assign a Password for user logon. 
CheckCon passwords need to be at 
least 6 Characters long. Repeat the 
password in Confirm Password to 
avoid mistyping. 

Please note that any CheckCon ac-
count needs a password, even those 
that are configured for autologin (see 
Connection to system users). 

Assign the CheckCon permissions for 
this user account. The Rights list 

shows all available user permissions. A checked box indicates that the user has the 
permission and can perform the corresponding action, an unchecked box indicates 
that the permission is not granted and the user is prohibited from performing the 
corresponding action. 

When the account configuration is complete, click [OK] to save the account into the 
user database. 

Edit existing accounts 

Select (highlight) the account you want to edit and click [Properties]. You will see 
all account properties in a nearly dialog identical to the New User dialog shown 
above, only the password boxes are missing. You can change all properties and 
permissions for the selected user here. Click [OK] to apply the changes when you 
are done. Passwords can not be changed here. Only the user themself can change 
their own password (see section Change password below for details). 

Delete account 

Select (highlight) an account in the account list and click [Remove] in order to de-
lete an account. 

Change password 

Click [Change Password] in the user 
manager to open the corresponding dia-
log. If the currently logged on user does 
not have the user manager permission, 

he can only change the password of the currently logged on account and the 
Change password dialog automatically relates this correctly. 
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If the currently logged on user does have the user manager permission, [Change 
Password] opens the Change password dialog not for the currently logged on ac-
count, but for the account currently highlighted in the account list. 

Enter the old (=current) password of this ac-
count for authentication and enter the new 
password twice as a precautionary measure 
against mistyping. 

So in any case, entering the current pass-
word is mandatory. If the administrator 
needs to change the password for an account 
where the current password is not known, 

the only way to do so is to delete the account and create a new one under the same 
name. 

Connection to System Users 

In the register Connection to system 
users of the user manager, you can 
assign one or more Windows ac-
counts to each CheckCon account. 
You can further decide whether the 
autologin feature shall be enabled or 
not. See the next section Autologin 
for details.  

The list shows all existing associa-
tions between (CheckCon) users and 
(Windows) system users.  

You can [Add] a new association, 
[Remove] an existing one or edit the 
[Properties] of an existing associa-
tion, analogous to the homonymous 
buttons on the register User. Please 
see section Adding a connection to 
system user accounts below for fur-
ther details. 

The automatic login feature is the 
sole purpose of this account associa-

tion. If you do not plan to use autologin, spare yourself the trouble of setting up 
account associations. 

Autologin 

Associations between CheckCon and system users allow for an automatic Check-
Con login. The autologin is activated in the Connections to system users register of 
the user manager. 

With the autologin deactivated (default), all users must log in explicitly to CheckCon 
by means of entering logon credentials in the Login dialog. With autologin activated, 
the system account currently logged in to Windows is looked up in the Connection to 
system users list on each start of CheckCon, and if present there is automatically 
logged on to CheckCon with the associated CheckCon account.  
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This enables you to authenticate users by means of a Windows domain and assign 
the rights within CheckCon by means of the connection to the system users. 

Adding a connection to system user accounts 

To add a connection, click [Add] in the 
register Connection to system users of the 
user manager. The dialog shown to the 
left opens. 

Select the CheckCon account from the 
drop-down list, to which you want to as-
sign Windows accounts. Only those 
CheckCon accounts are available here for 
which no association exists yet. 

Enter the Windows accounts to be asso-
ciated into the field system users, each 
on a separate line. You can also query 
your Windows user base by [Find system 
user]. Depending on your system and 
installation you will be able to browse the 
user base, for instance by means of active 
directory, and select the Windows ac-
count rather than typing it. 

If you want your CheckCon accounts to 
define roles rather than individual user 
accounts, you can assign several Win-
dows accounts to one CheckCon account. 

After you entered all Windows accounts, it is a good idea to [Check names] before 
you go on. If Windows can not resolve any of the entries into valid accounts, you 
will see an error message. The list will be checked top down and the first irresolv-
able entry produces the error message. So after correcting the entry, continue to 
[Check Names] until no error message pops up. 
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5 The main window 

The CheckCon main program window is diverted into a menu bar with command 
menus, a tool bar with short-cut icons, a navigation tree in the left pane and a de-
tailed view in the right pane as well as a status bar. This common layout is com-
pleted with a modus selector and a search option. Please note that the mode, 
search and tool bar are freely moveable and might on your system be arranged dif-
ferent from the layout shown in the picture above. In addition, display of each as 
well as of the status bar can be toggled on/off with the respective commands in the 
View menu. 

Navigation tree 

The CheckCon database forms the topmost level in the navigation tree. The next 
level downward consists of the customers. Below each customer lie the orders of 
this customer. To each order, any number of charges can be defined. 

Detail pane 

Select any item in the navigation pane to see a detail view of its contents and/or 
properties in the detail pane. 

Modus bar 

In the modus bar you select the CheckCon mode. You can alter between Current-
transformer and Voltage-transformer. Since management of the two types is quite 
different for each, the complete program adjusts to this setting. Only the customer 
database remains identical in both modes. 

The same setting can be performed in the Mode menu. 

The display of the mode bar can be toggled on/off in the View menu. 

Search bar 

The search bar allows searching for a charge in the complete customer database. 
Just enter what you know from the charge description into the field Charge and 
[Search]. 

Searching starts at the current position in the detail pane, provided the detail pane 
shows charges. Otherwise it starts at the current position in the navigation pane. If 
a charge is found, it is shown highlighted in the detail pane while the related order 
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is shown and highlighted in the navigation tree. If the search reaches the end of the 
customer list (as shown in the navigation tree) it continues the search from the be-
ginning. If a charge is found and displayed and you want the search to continue to 
find more hits, just click [Search] again. 

The display of the search bar can be toggled on/off in the View menu. 

Tool bar and status bar 

The icons on the tool bar represent short-cuts to the most commonly used features 
of CheckCon. Throughout this documentation wherever a function is described to 
which a short-cut icon exists on the tool bar, the icon is shown to the right of the 
description text. 

The status bar shows the current program mode on the left and the currently logged 
in account on the right. 

The display of the tool bar and of the status bar can be individually toggled on/off 
in the View menu. 

Add, edit and delete customers 

To add a new customer to CheckCon, highlight the database in the navigation 
tree and select Edit > New. 

Enter the customer’s name, street,  
zip-code and city. After you confirm 
with [OK], you will find the new entry 
in the navigation tree. 

To edit existing customer data, 
highlight the corresponding 
entry in the navigation tree and se-
lect Edit > Edit. Alter data as desired 
and confirm with [OK]. 

To delete an existing customer, 
highlight the corresponding 
entry in the navigation tree and se-
lect Edit > Delete or hit <Del>. Con-
firm with [OK] to delete the customer 

entry from the database. 

There are two ways to just view customer data. When you highlight a cus-
tomer in the navigation tree or detail pane, you can select Edit > Display from 
the menu. Alternatively, CheckCon displays the data when you perform a double-
click on a customer name in the detail pane. 

Add, edit and delete orders 

To create a new order number under a given customer, 
select the customer in the navigation tree and select 
Edit > New. CheckCon will present you an editable entry 
New order number, just like with a New folder in the Win-
dows explorer. Enter the order number, which automatically 
overwrites the default entry New order number and conclude 
with <Enter>. 
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To edit an order number, highlight the order number in the navigation pane 
and select Edit > Edit from the menu. The order number will become editable 
again. The same can be achieved when performing a single click on an already high-
lighted order number. (Pause a second between the first click for highlighting and 
the second for editing the entry, as two clicks in rapid order will be interpreted as 
double-click, which will not do the same). Change the order number as needed and 
conclude with <Enter>. 

To delete an order number, highlight the corresponding entry in the naviga-
tion tree and select Edit > Delete or hit <Del>. Confirm with [OK] to delete the 
order number from the database. 

Add, edit and delete charges 

To create a new charge under a given order number, select the order number 
in the navigation tree and select Edit > New. 

Enter a name for the new 
charge. 

Select the type of the trans-
formers in this charge. You 
can either select the type di-
rectly from the drop-down box, 
or open the complete list by 
clicking [>>], the latter allowing 
you to [Search] for a type, 
which becomes useful as the 
list of transformer types grows. 

Select the test sequence for 
this charge. Again, you can 
either select the type directly 

from the drop-down box, or open the complete list by clicking [>>]. There is no 
search feature for test sequences, since the list is not expected to grow to a size that 
would require a search. 

To edit a charge, highlight the charge in the navigation pane and select Edit > 
Edit from the menu. Change the data as needed and confirm with [OK]. 

To delete a charge highlight the corresponding entry in the detail table and 
select Edit > Delete or hit <Del>. Confirm with [OK] to delete the charge from 
the database. 

There are two ways to just view charge data. When you highlight a charge in the 
detail pane, you can select Edit > Display from the menu. Alternatively, CheckCon 
displays the data when you perform a double-click on a charge in the detail pane. 

Delete transformers from a charge 

Highlight a tested (red flagged) charge in the detail pane and select Edit > De-
lete test results from the menu. 

A red flag marks a tested charge, a blue flag indi-
cates that the charge is still to be tested. 

Doing so opens a dialog (shown below) in which 
you can select specific transformers for deletion. 
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Highlight any selection of transformers in the list 
for deletion. Use <Shift> and <Ctrl> for multiple 
selections as used from Windows. If you want to 
highlight all, check the box Mark all (uncheck to 
remove all highlighting). 

Click [OK] to remove all selected transformers 
from the charge.  

 

 

 

 

 

 

Printing 

You can print a test protocol for any transformer of an already tested charge. 
Select Edit > Print protocol from the menu.  

Highlight any se-
lection of trans-
formers in the list 
on the left for the 
protocol. Use 
<Shift> and <Ctrl> 
for multiple selec-
tions as used from 
Windows 

Select the Mode of 
protocol, choose 
between single pro-
tocol, total protocol 
and total protocol 
(short). 

The single protocol 
is designed for a 
single transformer, 
so in order to gen-
erate a single pro-

tocol, only one transformer may be highlighted in the list. 

Enter a Protocol number, Header data und Footer data as desired. Chose 
whether to Print customer data and order number on the protocol and confirm 
with [OK] to start printing. 

The same dialog opens for Edit > protocol preview. The difference is that after 
[OK] the protocol is shown in a preview window on screen instead of sent di-
rectly to the printer. You can then print the protocol from the preview window. 

Owners of a label printer can print (adhesive) labels for the tested transform-
ers by Edit > print label. The label printer must be connected to the machine 
and the system port specified in Extras > Adjustments, register Interface settings. 
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Highlight a transformer in the list of the left.  

Add information about the tester and a re-
mark if desired.  

[Print] the labels for the selected transformer. 

[Interface] allows you to directly monitor the 
communication between CheckCon and the 
label printer for diagnostic purposes. See sec-
tion 13  

 

 

 

Finally, you can print an overview over all charges for a given (highlighted) 
order number by selecting Edit > print charge overview from the menu. 

Exporting results 

You can export the test results for any tested transformer. Click Extras > Export 
results in the menu. This opens a standard Save as... dialog, in which you must 
specify the export file (.mdb). If you select an existing file it will be overwritten with 
the current data.  

This new export file is added to the list of index tables (see below). CheckCon will 
ask you whether you want to delete the exported results from the program data-
base. Since the results are now stored in the export database and still available via 
the index table system, you can delete the results from the program database to 
keep it small and fast. Since results can not be appended to existing export data-
bases, you should only export the results of completed test sets for which no new 
results will need to be added. 

Index table configuration 

The index table configuration, Extras > index 
table configuration, allows you to manage all ex-
ported results, provided they are available as 
Access (.mdb) database files. 

It features a list of all available export database 
files. If an existing database file is not listed 
here, you can [Add] it, which opens a standard 
Open file dialog.  

If an entry points to a database which is no 
longer needed, highlight it in the list and 
[Delete] it. 

The column entry count shows the number of 
results contained in each database file. 

Check a database Active to have it included in the search when searching for 
transformers (see next section). Click [OK] to apply changes to the active selection. 
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Searching transformers 

Select Data > Search transformer from the menu, to open the search dialog. 

Enter any search criteria in the 
appropriate fields in the upper 
area. 

Check Consider results of the 
index tables when you want to 
extend the search to the index 
tables, which means all index 
tables that are marked Active in 
the index table configuration (see 
above). 

Start the [Search].  

All results that match the search 
criteria are shown in the lower 
area on the window. The right-
most column of the result list 
shows whether the transformer 
was found in the program data-
base or in the index tables.  

When you highlight a result from the program database and press [Go to...] you 
switch back to the CheckCon main window with the corresponding charge dis-
played in the detail pane. 

[Print statistics] and [Print preview statistics] print respectively preview a statis-
tics sheet about all listed results, [Print] prints the results for the highlighted trans-
former. The print and preview dialogs are described in the section Printing above. 
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6 Settings 

The basic settings of CheckCon 2005 can be viewed and edited in the settings 
dialog behind Extras > Adjustments. 

General 

 

Click [Database...] to open the standard Windows Data sources (ODBC) dialog 
(Same as [Start] > Control Panel > Administrative Tools > Data Sources). Here, the 
ODBC connection for CheckCon 2005 can be established, should this not auto-
matically happen during setup, or changed, should the need arise. Select a connec-
tion and confirm with [OK]. 

After selecting a new data source, CheckCon must be restarted before the changes 
take effect. 

In the area Report folder please specify the path to the CheckCon reports. 

Specify the number of transformer test slots on your test equipment in the field 
Count of meter places. Specify the Number of decimal places you wish to see in 
the error values for ratio error and phase displacement..  

The Certification number consists of two parts,  number and year.  

For the Interturn insulation test you can chose between single and collective, with 
single meaning the test is performed on one transformer after another while collec-
tive means all are tested simultaneously. 

To print a Label after tests, select Yes in the 
corresponding drop down box. 

In the area Asset configuration, please check 
whether your test equipment supports the High 
voltage test, Secondary current factor and 
Knee-point voltage.  
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Current transformer 

 

For the Interturn insulation test, Demagnetization, Accuracy test und Secon-
dary current factor, please specify the increase rate and the decrease rate in 
[%/s]. For the interturn insulation test the test length is required additionally.  

If the Accuracy test shall be performed taking the correction values into account, 
select Yes in the drop down box with correction. Configuration of correction values 
is described in section 7 (Corection Values). 

In the area Check test point specify the test current and ratio error in % and phase 
displacement in minutes. If you enter 0 (zero) a test current percentage, check test 
point will not be executed. 
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Voltage transformer 

 

For the Insulation test and Accuracy test, please specify the increase rate and the 
decrease rate in [%/s]. For the insulation test the test length is required addition-
ally.  

If the Accuracy test shall be performed taking the correction values into account, 
select Yes in the drop down box with correction. Configuration of correction values 
is described in section 7 (Correction Values). 

In the area Check test point specify the test current and ratio error in % and phase 
displacement in minutes. If you enter 0 (zero) a test current percentage, check test 
point will not be executed. 
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Interface settings 

 

 
Assign the appropriate interface port to each connected device. Since each interface 
port can only feature a single device, a given port can not be assigned more than 
once. Leave the drop-down box empty for devices that are not connected to your 
machine. 

Any changes on this register require a restart of CheckCon in order to take effect. 
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Test conditions 

 

Apart from the SES, automatic testing is only possible if your testing equipment 
features a PLC. Please specify whether a PLC exists or not. 

Then, for each device, select whether the test will be performed manually or auto-
matically. A manual test requires the tester to perform the necessary operation 
manually during the test, CheckCon will announce the necessary steps during the 
course of the test. 
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Handheld 

 

Handheld or terminal refers to the mobile hand-held combination of keypad and 
barcode scanner, which allows the user to collect the required data in place going 
from one testing place to another. After data collection is completed, the handheld 
is put into a docking station to allow data transfer to CheckCon. 

Since a single terminal covers only a limited number of testing places (usually 10), 
you might have more than one in use, each with its own corresponding docking sta-
tion. In the area terminals and places you assign each terminal to the testing places 
it covers. The first column shows the terminal number, column 2 and 3 define the 
corresponding range of testing places. 

To allow for proper data collection and exchange, the handhelds must be properly 
programmed before you can use them. 

In the area Field specifications all required specifications must be declared. A 
specification consists of a Key and a Field specification.  

The keys correspond to the transformer registers. To assign a specification to a reg-
ister, select the corresponding key from the list and enter a unique specification. 

To add a new specification, select the key corresponding to the desired register 
from the drop-down box Key:. (the drop down box features all customary keys as 
default) and enter the desired Field specification in the input field left to it. 

Usually, the values for the specifications may not exceed a length of 10 characters. 
If the expected values for the new specification might exceed 10 characters, please 
check them as Wide, which will allow the specification to store values of up to 20 
characters length. The terminal shows those values split up on two lines. 

CheckCon can check whether a given specification assumes identical values on dif-
ferent transformers. For most specifications, those duplicates are noncritical or 
even required (many transformers will show the same year of construction, for in-
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stance), so duplicates are allowed per default. If you want CheckCon to prevent a 
specification from assuming an identical value on different transformers (id num-
bers, for example), remove the check mark from the checkbox Dupl. 

Finally, click [add], to add the new specification to the list. 

When you highlight a specification, the current values are copied into the input 
fields above the list. Now, you can  

� click [Delete] to delete the specification. 

� edit the values and click [Change] to alter the specification. 

� edit the values and click [Add] to create a new specification, useful for creating 
several similar specifications. 

� reposition the specification in the list by means of the up and down arrow but-
tons down right beside the list field. 

The specification Property number, Manufacturer number and Manufacturing 
year should be defined in any case, and always in this order. They are needed to 
properly identify the transformer in the automatic test. 

The [Program]-button is only active if you use a terminal and have it connected. It 
allows you to [Program] all specifications into the terminal, so the corresponding 
data can be collected with the handheld. During the programming of the handheld, 
you can monitor the data transfer on the [Interface] for diagnostic purpose. See 
section 13 Interface for details. 
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7 Device configuration 

Open Extras > Device Configuration.  

The four registers all work in the same way. The left side features a navigation pane 
with two separate trees, one for current transformers, and one for voltage trans-
formers. The trees might contain entries, in which case each entry resembles a cer-
tain configuration. The right pane shows the detail data for the entry currently 
highlighted in the tree.  

Right-clicking an entry in the tree opens a context menu al-
lowing to add a new entry to the tree, or to remove the cur-
rently highlighted one. 

Each dialog features two buttons [Save to file] and [Load 
from file], which allow you to export the currently high-
lighted entry to an external file, or import from such a file 
respectively. You can use this feature, for instance, to trans-
fer existing configurations from one machine to another. 

The external file is in XML format. 

Burden 

 

Here you configure all burdens connected to the testing equipment. 
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If the burden supports so, try to [Read from burden] to determine the correct con-
figurations automatically. 

When reading from the burden, [Interface] allows you to monitor this communica-
tion. 

If you need to fill the table manually, do as follows:  
From the context menu of the navigation pane add a new configuration and give it 
a name. Add all value pairs of VA and Cos β for this configuration into the upper 
table. The lower table contains all valid settings for secondary current or secondary 
voltage, where for the secondary voltage you can additionally define whether to di-
vide it by 3 (/3) or by the root of 3 (/v3). 

Current range 

 

Define the current range for current and voltage transformers. 

Specify the primary voltage or current and add the value or percentage for the out-
put. 
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Standard transformer 

 

For voltage transformers you specify primary and secondary voltage and determine 
for both whether the values are to be divided by 3 (/3) or by the root of 3 (/v3).  

For current transformers you only specify primary and secondary currents. 
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Correction values 

 

Specify the correction values for the transformers. For each pair of primary and 
secondary quantities, specify correction values for current, ratio error and phase 
displacement. 

The correction values are used in the accuracy test, if this is activated in the corre-
sponding settings (see section 6, subsections voltage transformer and current trans-
former). 
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8 Transformer type and windings 

Manage transformer types and their respective windings with the transformer 
type list at Data > transformer type. 

Add new transformers by [New] (from scratch) or 
by [Copy] (using the currently highlighted trans-
former as template). 

Both options open a property dialog for the 
transformer (see below), in which you can spec-
ify all detail data. 

You can [Delete] the currently highlighted 
transformer or [View] its detail data. You can 
only [Edit] a transformer, when it is not in-
cluded in any charge at that time.  

For larger lists, instead of scrolling, you might 
want to [Search] for a transformer by its name. 

Finally, you can [Print] an overview over all 
transformers contained in the list. 

[New], [Edit] and [Display] open the following dialog: 

 

The area Transformer type contains the general data of this transformer. 

The Winding list allows you to specify the windings of this transformer. The but-
tons [New], [Delete], [Edit] and [Display] work identically to the other dialogs and 
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allow you to add or remove a winding number and to edit or view the details re-
spectively. 

The detail data of the windings 
is presented in a separate 
mask, as shown to the right. 

Enter general winding data in 
the upper fields of the dialog. 
Select an error class for that 
winding. Please refer to section 
10 Error Classes for details 
about error classes. Instead of 
typing the name of the error 
class, click [>>] to select one 
from the list. 

For each winding please check 
Single winding summary 
transformer or Rogowski coil 
where appropriate. 
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9 Test Sequence 

Manage the test sequences in the test sequence list at Data > Test sequences. 

Add a new test sequence by [New] (from scratch) 
or by [Copy] (using the currently highlighted 
sequence as template). 

Both options open a property dialog for the test 
sequence (see below), in which you can specify 
all detail data. 

You can [Delete] the currently highlighted test 
sequence or [View] its detail data. You can only 
[Edit] a test sequence, when it is not included in 
any charge at that time.  

Finally, you can [Print] an overview over all test 
sequences contained in the list.  
 

[New], [Edit] and [Display] open the following dialog: 

 

In the area Test sequence please enter a name for the new test sequence in the 
field Test program and add a Description if desired. 

If you checked High Voltage Test capability for your test equipment in the settings 
(see section 6 Settings General), here you can activate the High voltage test for this 
test sequence.  

Add the values for Interturn insulation test, Voltage limit and Increase rate.  
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In the current transformer mode of CheckCon (as shown above) a value for Demag-
netization is required.  

In the voltage transformer mode instead you need to 
specify, or rather select the frequency. Additionally, you 
can select 1/4 Burden at nominal power >= 60VA 
equals  15 VA to cap the maximum burden power . The 
different section of the dialog is shown to the right. 

In the detail pane of the dialog, the area test point, indi-
vidual test points can be specified. The columns of the 
table have the following meanings: 

Winding no: The winding number to be tested in this test point  

Demag(netization), Security current and Kneepointvoltage: You can select only 
one of the three options. Security current and Kneepointvoltage are only avail-
able if configured for your test equipment in the settings (see section 6 Settings – 
General for details). 

If none of the boxes for Demag, Security current and Kneepointvoltage is checked, 
you must provide values for test voltage (%) or test current (%) (depending on 
mode) and burden. The burden can either be specified as Burden (1/Sn) (third col-
umn) or as Burden (VA) (fourth column). Specifying both is not possible, if you en-
ter values in both fields, Burden (1/Sn) takes precedence. 

If the test sequence is completely defined, click [OK] to save it and close the dialog. 
You can also [Print] out any complete test sequence including all detail data or 
[Cancel] at any time. 
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10 Error Classes 

The list of error classes is available via Data > Error class from the menu. This 
list allows you to manage the error classes. 

To add a new error class, either create a [New] 
one, starting empty, or [Copy] the currently 
highlighted class as template for the new one. 
Copying only asks for a name and creates an 
otherwise identical class. [Edit] the new class to 
adjust the detail data. 

You can [Delete] the highlighted class, remov-
ing it from the database. 

You can [Display] the detail data at any time, 
[Edit] only when they are not assigned to any 
transformer at that time. In order to edit an er-
ror class currently assigned to transformers, 
you would first need to delete any such trans-
former. 

You can [Print] an overview over all error classes including all details. 

[New], [Edit] and [Display] open the following detail data dialog: 

In the area Error class, 
enter a Name and De-
scription for the error 
class. 

Define the individual test 
points in the table test 
point. Enter test current 
(%) or test voltage (%) 
(depending on mode). Add 
maximum deviation (%), 
maximum ration error 
(%) and maximum phase 
displacement (minutes). 

You can [Cancel] at any 
time and [Print] out the 
error class with its cur-
rent detail data. Confirm 
by [OK] when you are 
done to save the changes. 
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11 Automatic test 

To start the automatic test, highlight a charge in the detail pane of the main 
CheckCon window and select Test > Automatic Test. 

The dialog shown above opens, which serves to start and stop as well as monitor a 
running test. It shows the charge name, the transformer type and the name of the 
test sequence in the upper area for reference. Click the corresponding [Details >>] 
to display full details. 

Test mode shows, which test is currently performed and the current test action. 

Current test parameters for current/voltage, ratio error and phase displace-
ment are shown in the area test data. Values that are out of their valid range are 
shown in red. To monitor the test data from a distance, you can [Zoom] these three 
parameters into a magnified display. 

Right beside the test data detail data for the current test place are displayed. 

[Start] the test when ready. [Interface] allows you to monitor the raw communica-
tion between CheckCon and the individual devices in a separate window, see sec-
tion 13 Interface monitoring for details. You can [Stop] a running test at any time. 

Should any disturbance occur, an error message will be shown in the field Failure. 

When you are done, just [Close] the window. 

When you [Start] the test, CheckCon asks for the property number, manufacturer 
number and manufacturing year of the currently tested transformers. You can either 
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input the data manually into the table or 
read it from a handheld, if connected, by 
[ET readout].  

You can erase the transformer data in the 
handheld by [ET delete]. As usual, [Inter-
face] allows monitoring the raw commu-
nication between CheckCon and the de-
vice, here the terminal. 

When you need to input the data manually, [Copy / Continuous] allows you to 
copy the data of the currently highlighted line into all subsequent lines, while in-
crementing the values of property number and manufacturer number by 1. 

When all detail data are entered, click [OK] to 
confirm and to start the test.  

After the end of the test, another dialog shows 
you the evaluation of the just finished test. 
Please check the Certification number and the 
Certification year. You can correct the values, 
where necessary. This dialog also features the 
[Copy / Continuous] button, which works as 
described above. 

After you confirm the results with [OK], the results are saved into the database and 
the test is started anew for the next set of transformers. 
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12 Manual test 

 

CheckCon allows to manually performing a partial test. Manual tests do not 
create regular test results, nothing will be stored in the result database. To 
start a manual test, select Test > Manual Test from the menu. 

Test mode shows, which test is currently performed or about to be performed and 
the current test action. The drop-down box Mode on the top of the test detail data 
allows you to select the test mode prior to starting. In addition to the Mode, please 
specify all detail data as required for the selected test. 

In the fields Transformer/Terminals you specify in detail, which terminals at 
which transformer are to be tested. Terminals here refers to the transformer termi-
nals, the electric connectors of the transformer, not the handheld device.  

Please note that only those fields are available, that will be evaluated for the test 
type you chose in Mode. Also, some combinations may not be valid, for instance the 
specified test currents must be supported by the selected burden. 

[Start] the test when ready. 

Current test parameters for current/voltage, ratio error and phase displace-
ment are shown in the area test data. Values that are out of their valid range are 
shown in red. To monitor the test data from a distance, you can [Zoom] these three 
parameters into a magnified display. 

[Interface] allows you to monitor the raw communication between CheckCon and 
the individual devices in a separate window, see section 13 Interface monitoring for 
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details. The manual test does not halt by itself, you can [Stop] a running test at any 
time. 

Should any disturbance occur, an error message will be shown in the field Failure. 

When you are done, just [Close] the window. 

During the test you can [Save the current test point] at any time. This will export 
the parameters of the current test point into a file ManTestLog.txt, located in the 
CheckCon program directory.  

 



  CheckCon 2005 User Guide   

46 

13 Interface monitoring 

 

 

Whenever CheckCon communicates with one of the connected devices, the corre-
sponding dialog allows you to monitor that communication by means of an [Inter-
face] button.  

This opens a separate window which shows all commands and data exchanged be-
tween CheckCon and the device in real-time. 

Data that go from CheckCon to the device carry the prefix COMx Out, where x is 
the number of the interface port the device is actually connected to. Data that go 
from the device to CheckCon have the prefix COMx 
In.  

If you want to delete the content of the window in 
between monitoring, right-click into the window and 
issue the Delete command. 

 

 

 


